Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: Weiße Blöcke in meiner Website

  1. #1
    HTML Newbie
    Registriert seit
    14.06.2006
    Beiträge
    3
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Weiße Blöcke in meiner Website

    Hallo zusammen,

    ich arbeite gerade an meiner ersten Homepage, die etwas ordentlicher daherkommen soll, als die üblichen "ersten Versuche".

    Ich habe das Konzept aus einer .psd Datei genommen, Slice drauf und dann als HTML abgespeichert.

    Soweit, so gut!

    Dann habe ich die Seite bearbeitet und bin zu einem Ergebnis gekommen:

    Mit Opera sieht das ja auch unglaublich schick aus.

    Hier zu sehen!

    Aber wer kein Opera hat, sieht schon das Problem.
    Überall sind diese scheußlichen weißen Balken.

    Wo kommen die her und wie kann ich sie dahin zurückschicken, wo sie herkommen?

    (Die Seitentitel werden natürlich noch geändert, ebenso wie der Domainname)


    Schonmal vielen Dank für eure hoffentlich kommende Hilfe!
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Forum Guru
    Registriert seit
    14.06.2004
    Ort
    Schleswig-Holstein
    Beiträge
    5.439
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Moin!

    Ich hab mir grade mal den Quelltext angesehen, warum schneidest du die Grafuik überhaupt?

    Ich meine, außer einer Tabelle mit div. Grafiken ist ja eigentlich gar nichts da.

    Du solltest dich mal mit HTML vertraut machen, so wie jetzt wird das nie eine Homepage.

    Wo das Problem nun genau liegt?
    Ehrlich gesagt ist es mir zu mühsam die ganzen Schipsel und Tabellenfragmente zu analysieren, da es keinen Wert hat, denn es wäre Arbeit für den Mülleimer.

    G.a.d.M.

    Ronald

  3. #3
    HTML Newbie
    Themenstarter

    Registriert seit
    14.06.2006
    Beiträge
    3
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Ok, Folgendes:

    Um aus einer Photoshop Datei eine Webseite zu machen, muss ich slicen.
    Also das Bild in kleine Schnipsel unterteilen.

    Das klappt auch alles wunderbar und alle Browser kommen damit klar.

    Wenn ich dann aber aus einem Schnipsel einen Link mache, entstehen automatisch diese Balken.

    ein bekannter meinte, es liegt an den unterschiedlichen Colspan Werten der Tabellenteile.

    Wäre wirklich klasse, wenn mir da jemand helfen könnte, da es mir recht wichtig ist, dass die Seite bald steht.

    HTML lerne ich überigens schon, aber das geht leider nicht von heute auf morgen, wie ihr selber wisst.

  4. #4
    Forum Guru
    Registriert seit
    14.06.2004
    Ort
    Schleswig-Holstein
    Beiträge
    5.439
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Wenn du es mit HTML machst, dann benutzt du das komplette Originalbild als Hintergrund und legst die Grafiken darüber.
    Die Texte werden als Text dargestellt und nicht als Grafik.
    Glaub mir, brich den Versuch an dieser Stelle ab und beginne mit HTML neu, sonst packt dich schon bald der Frust und du kommst langsamer vorwärts als ne Schnecke beim Überqueren einer Autobahn.

    Ist nur ein Rat, aber ein gutgemeinter.

    G.a.d.M.

    Ronald

  5. #5
    HTML Newbie
    Themenstarter

    Registriert seit
    14.06.2006
    Beiträge
    3
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Hm, dann habe ich ja wohl keine Wahl, oder?

    Dann werde ich mal schauen, wie ich das mit HTML hinkriege, wenn keine herausragenden Ratschläge mehr kommen, womit ich nicht rechne.

    Dann aber trotzdem schonmal vielen Dank für den gutgemeinten Rat!

  6. #6
    Prinz(essin) Avatar von Lizzard
    Registriert seit
    19.02.2006
    Ort
    München
    Beiträge
    788
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Hi,

    die weißen Ränder bei dir entstehen, weil die Bilder border haben.

    In jeden Img-tag der Link ist, einfach noch border="0" einfügen, und schon verschwinden deine Weißen Rahmen
    also dann [img]BILDURL[/img] und schon funktionierts.

    MfG
    LizZard
    Sometimes you have a programming problem and it seems like the best solution is to use regular expressions; now you have two problems.

  7. #7
    Gast

    Standard

    Lizzard, du bist mein Held!

    Das klappt ja wirklich. So einfach und schnell!

    Vielen, vielen Dank!

    Aber ich weiß auch, dass mich das nicht davor retten wird, HTML zu lernen.

    Danke für eure Hilfe, Leute!
    Ich werde euch dann mal Bescheid geben, wenn das Ergebnis steht!

  8. #8
    Forum Guru
    Registriert seit
    14.06.2004
    Ort
    Schleswig-Holstein
    Beiträge
    5.439
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Falls du es schon online hast: bei mir verschiebt sich immer noch alles und überall sind weiße Balken.

    G.a.d.M.

    Ronald

  9. #9
    Kaiserliche Hoheit Avatar von No0ob
    Registriert seit
    02.01.2006
    Ort
    Nähe Frankfurt
    Beiträge
    1.500
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Es ist einfacher, wenn du zwischen den Head tags folgendes definierst:
    Code:
    <style type="text/css>
    img &#123; border&#58;none; &#125;
    </style>
    Damit ersparst du dir, in jeden <img>-Tag das Attribut border="0", bzw. style="border:none," zu schreiben

  10. #10
    Gast

    Standard

    Auch dir vielen Dank, aber die Euphorie des Sieges hat mich bereits veranlasst, überall ein border="0" einzufügen.

    Das Endergebnis steht nun also.

    Was sagen die Profis? Für eine erste Webseite in Ordnung, oder sollte ich mich doch lieber dem Stricken oder Baggerfahren zuwenden?

Ähnliche Themen

  1. WYSIWYG - Editor für User auf meiner website gesucht
    Von help mee im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 2
    Letzter Beitrag: 05.05.2007, 19:37
  2. Aufteilung meiner Website
    Von Tikonteroga im Forum HTML & CSS Forum
    Antworten: 4
    Letzter Beitrag: 28.12.2006, 14:51
  3. Von Suchergebnisse auf Startseite meiner Website
    Von aussie im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 6
    Letzter Beitrag: 22.12.2006, 23:45
  4. Farben meiner Website ändern
    Von SP965 im Forum HTML & CSS Forum
    Antworten: 10
    Letzter Beitrag: 20.09.2006, 21:38
  5. Problem beim Veröffentlichen meiner Website
    Von unbekannter im Forum HTML & CSS Forum
    Antworten: 6
    Letzter Beitrag: 12.12.2003, 19:47

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •