Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: inculde mit php funzt nicht!

  1. #1
    Gast
    Gast

    Standard inculde mit php funzt nicht!

    Hallo,

    folgendes Problem:
    Ich habe diese seite: http://forum.yboard.de/?op=anmelden
    Dort seht Ihr ein Anmedle Formular. Die Seite besteht aus header.php, inc_anmeldung.php und footer.php.
    Jetzt hat meine Seite aber auch eine Startseite, das ist www.yboard.de
    Ich möchte nun die inc_anmeldung.php auf meiner Starseite www.yboard.de auf der rechten Seite include, wo bis jetzt die Grafik "zur Anmeldung" ist.
    Die Startseite ist eine .htm seite. In Ihr habe ich folgendes versucht:

    Code:
    <? include&#40;"http&#58;//www.yboard.de/forum/inc_anmeldung.php"&#41;; ?>
    Dann kommt da aber nichts.
    Wenn ich / oder ihr mal versucht, die inc_anmeldung mal alleine auf zurufen, also www.yboard.de/forum/inc_anmeldung.php, kommt auch nix!

    Was läuft da falsch
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Großmeister(in)
    Registriert seit
    06.06.2005
    Beiträge
    545
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Ganz einfach, weil der include Befehl ein php-Befehl ist und somit nur in php Seiten funktioniert. Du musst also entweder aus deiner Startseite die jetzt die Endung .html hat eine php Seite machen mit der Endung .php. Da kann es aber vorkommen dass du noch ein paar andere Sachen ändern musst. Oder du "includest" deine Seite mittels Frames oder IFrames. Ich würd dir aber zu IFrames raten wenn ich mir den Quellcode deiner Startseite ansehe.

    Code:
    <iframe name="beispiel" src="forum/inc_anmeldung.php"></iframe>

  3. #3
    Gast

    Standard

    Hallo,

    Iframes hab ich schon versucht, aber die blöde inc_anmeldung.php lässt sich ja nicht einzeln aufrufen!!!
    Schau mal www.yboard.de/forum/inc_anmeldung.php

  4. #4
    Kaiser(in)
    Registriert seit
    09.12.2005
    Alter
    29
    Beiträge
    2.496
    Danke
    1
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    lässt sich aufrufen
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML><HEAD>
    <META http-equiv=Content-Type content="text/html; charset=iso-8859-1"></HEAD>
    <BODY></BODY></HTML>
    der rest wird wohl php sein und wird deswegen nicht angezeigt
    Sei immer du selbst. Außer du kannst Batman sein. Sei immer Batman!

  5. #5
    Gast

    Standard

    ?
    Kommt bei dir was, wenn du auf den Link klickst?

  6. #6
    Gast

    Standard

    ACHSO das is der Quelltext, klar.

    Aber wie soll ich dann includen?

  7. #7
    Gast

    Standard

    Sorry für den Trible-Post:

    Also ich hab jetz was versucht:
    http://www.yboard.de/forum/testpage.php

    da gibts aber nur nen Felhler

  8. #8
    Großmeister(in)
    Registriert seit
    06.06.2005
    Beiträge
    545
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Ich glaub ich brauch nicht mal fragen, aber, du hast noch nie mit php gearbeitet, oder?

    In deiner testpage.php löscht du jetzt mal alles und fügst nur folgendes ein:

    <?php
    include ("inc_anmeldung.php");
    ?>

  9. #9
    Gast

    Standard

    Hab ich gemacht. Schau sie dir mal jetzt an, jetzt kommt gar nichts...

  10. #10
    Großmeister(in)
    Registriert seit
    06.06.2005
    Beiträge
    545
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Das passt ja auch, leider ist halt nur deine inc_anmeldung.php leer! Was soll er denn da großartig anzeigen?

Ähnliche Themen

  1. Diskettenklaufwerk funzt nicht!!!!
    Von ZOCKER2007 im Forum Computer - Internet Forum
    Antworten: 2
    Letzter Beitrag: 18.05.2007, 20:29
  2. Preloader funzt nicht...
    Von calvin_237 im Forum Flash Forum
    Antworten: 0
    Letzter Beitrag: 23.02.2007, 23:22
  3. verlinkung funzt nicht !
    Von webcool im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 1
    Letzter Beitrag: 11.01.2007, 16:11
  4. wordwrap funzt nicht :\
    Von gelöschter User im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 8
    Letzter Beitrag: 11.01.2007, 14:09
  5. IMG-Tag funzt nicht
    Von Romi im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 08.05.2003, 10:44

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •