Ergebnis 1 bis 4 von 4

Thema: MySQL Problem

  1. #1
    Gast
    Gast

    Standard MySQL Problem

    Hi,

    ich habe eine folgende Fehlermeldung bekommen:
    =========
    You have an error in your SQL syntax near 'FROM requests LEFT JOIN request_types ON (request_types.type_id = reques' at line 1

    SELECT SQL_CALC_FOUND_ROWS * FROM requests LEFT JOIN request_types ON (request_types.type_id = requests.type_id) LEFT JOIN user ON (requests.requester_user_id = user.user_id) WHERE (requester_user_id = '40') ORDER BY requests.request_id DESC LIMIT 0,100;
    ========
    Ich benutze im Moment phpMyAdmin 2.7.0-pl1 verbunden mit MySQL 3.23.47-max-debug von xampp-Paket.
    Die obere Request habe ich versucht bei phpMyAdmin 2.7.0-pl1 verbunden mit MySQL 4.0.16-max-nt auszuführen und es gab keine Fehlermeldung. Ich vermute die Syntax "SQL_CALC_FOUND_ROWS " funktioniert nicht bei MySQL 3.23.47 , sondern bei hörere Version, zB bei MySQL 4.0.16. Aber ich weiß nicht , wo ich ein Paket, das Apache, phpMyAdmin 2.7.0-pl1 verbunden mit MySQL 4.0.16-max-nt ,PHP hinkriegen kann. Weiß einer von Euch?
    Ich hoffe ich habe richtig vermutet, woran der Fehler liegt
    Danke
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Forum Guru
    Registriert seit
    28.12.2004
    Ort
    Ringgenberg(bei Interlaken) / Schweiz
    Beiträge
    4.787
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    SQL_CALC_FOUND_ROWS *

    gegen

    count(*) ersetzn

  3. #3
    Gast

    Standard

    Ich habe das auch herausgefunden. Weißt Du wie ich ein Paket, das apache, phpMyAdmin 2.7.0-pl1 verbunden mit MySQL 4.0.16-max-nt oder hörere Version ,PHP enthält, hinkriegen? Ich muß das haben für ein anderes Problem.
    Danke

  4. #4
    Forum Guru
    Registriert seit
    28.12.2004
    Ort
    Ringgenberg(bei Interlaken) / Schweiz
    Beiträge
    4.787
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    saug dir einfach eien xampp von apachefriends.de

    den bekommt man relativ fix auch sicher zum laufen aber so wie er ist reicht er für eine lan betriebe doch nicht gerad so fürs netzt, damust du den erst noch ein wenig absichern. Ist aber eien anleitung bei.

Ähnliche Themen

  1. UTF-8 Problem mit PHP und MySQL
    Von LinuxMan im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 2
    Letzter Beitrag: 10.08.2008, 20:26
  2. mysql problem
    Von im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 15.10.2006, 14:52
  3. Mysql-Problem
    Von BendOr im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 5
    Letzter Beitrag: 22.08.2006, 16:03
  4. MySQL Problem
    Von onlineuser im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 7
    Letzter Beitrag: 13.06.2005, 22:30
  5. mySQL problem
    Von gelöschter User im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 9
    Letzter Beitrag: 02.11.2004, 00:12

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •