Ergebnis 1 bis 6 von 6

Thema: Sicherheitslücken in PHP

  1. #1
    Administrator Avatar von admin
    Registriert seit
    16.01.2003
    Ort
    Karlsruhe
    Beiträge
    12.779
    Danke
    1
    Bekam 4 mal "Danke" in 2 Postings
    Blog-Einträge
    42

    Standard Sicherheitslücken in PHP

    Lese gerade einen Beitrag über Sicherheitslücken bei älteren PHP Versionen, die auch auf diesem Server noch im Einsatz ist.
    Ein Update auf die Version 4.4.1 wird empfohlen.
    Jetzt meine Frage
    Besteht eigentlich die Gefahr, das PHP Scripte, die auf meinem Server natürlich zu hauf im Einsatz sind danach nicht mehr laufen ?
    Was sagen die Profis hier im Forum dazu bzw wäre ein Update auf die PHP Version 4.4.1 sinnvoll !
    http://www.heise.de/newsticker/resul.../meldung/65598
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!
    Die Forenregeln und Nutzungsbedingungen sind auch zum lesen da !!!


  2. #2
    Forum Guru
    Registriert seit
    28.12.2004
    Ort
    Ringgenberg(bei Interlaken) / Schweiz
    Beiträge
    4.787
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Also eigentlich sind keine auswirkungen bekannt, sei denn du updatres gleich auf 5.1, da giebt es dinge die anders sind, bzw nicht mehr existent.

    Hast du register_globals on/off ???

  3. #3
    Administrator
    Themenstarter
    Avatar von admin
    Registriert seit
    16.01.2003
    Ort
    Karlsruhe
    Beiträge
    12.779
    Danke
    1
    Bekam 4 mal "Danke" in 2 Postings
    Blog-Einträge
    42

    Standard

    Also dürfte das Update keien Probleme mit meinen Scripte machen, richtig

    Zitat Zitat von GreenRover
    Hast du register_globals on/off ???
    ich glaube steht auf off
    Die Forenregeln und Nutzungsbedingungen sind auch zum lesen da !!!


  4. #4
    Kaiser(in)
    Registriert seit
    03.06.2004
    Beiträge
    2.557
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Zitat Zitat von admin
    Also dürfte das Update keien Probleme mit meinen Scripte machen, richtig

    Zitat Zitat von GreenRover
    Hast du register_globals on/off ???
    ich glaube steht auf off

    ...nein, es ist auf "on", sofern die homepage auf dem gleichen server liegt, wie der webspace den ich von dir hab.

  5. #5
    Forum Guru
    Registriert seit
    28.12.2004
    Ort
    Ringgenberg(bei Interlaken) / Schweiz
    Beiträge
    4.787
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Das register_globals on verbaucht ein wenig performance und stellt dazu eine große Sicherheitslücke da. Also wenn man nicht so sch.. Scripte hat die es erforderlich machen, sollte man es abstellen.

  6. #6
    Administrator
    Themenstarter
    Avatar von admin
    Registriert seit
    16.01.2003
    Ort
    Karlsruhe
    Beiträge
    12.779
    Danke
    1
    Bekam 4 mal "Danke" in 2 Postings
    Blog-Einträge
    42

    Standard

    Habe mich vertan
    register_globals steht auf on
    Habe aber auch Scripte, die das unbeningt brauchen und werde es deswegen auch auf on lassen


    @ Rocco: Dein Qebspace liegt auf dem selben Server wie das Forum
    Die Forenregeln und Nutzungsbedingungen sind auch zum lesen da !!!


Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •