Ergebnis 1 bis 4 von 4

Thema: was ist an diesem code falsch?

  1. #1
    FR0SCH
    Gast

    Standard was ist an diesem code falsch?

    hey leutz
    ich habe ein problem mit einem php-code mit mysql

    was ist an diesem code falsch?

    Code:
    <?
     mysql_connect&#40;&#41;;
     mysql_select_db&#40;'usr_p143_1'&#41;;
     $anfrage = "SELECT * FROM picsubject ORDER BY picsubject_full ASC";
     $ergebnis = mysql_query&#40;$anfrage&#41;;
     if &#40;mysql_num_rows&#40;$ergebnis&#41;>0&#41;
      &#123;
       while&#40;$picsubject1 = mysql_fetch_assoc&#40;$ergebnis&#41;&#41;
        &#123;
         echo "".$picsubject1&#91;"picsubject_full"&#93;."
    ";
        &#125;
      &#125;
     mysql_close&#40;$zugang&#41;;
     
     
     $switch_open = '<?switch&#40;$_GET&#91;picsubject&#93;&#41;&#123;';
     echo $switch_open;
     eval &#40;"\$switch_open = \"$switch_open\";"&#41;;
    
     mysql_connect&#40;&#41;;
     mysql_select_db&#40;'usr_p143_1'&#41;;
     $anfrage = "SELECT * FROM picsubject ORDER BY picsubject_full ASC";
     $ergebnis = mysql_query&#40;$anfrage&#41;;
     if &#40;mysql_num_rows&#40;$ergebnis&#41;>0&#41;
      &#123;
       while&#40;$picsubject2 = mysql_fetch_assoc&#40;$ergebnis&#41;&#41;
        &#123;
         $case = 'case \"".$picsubject2&#91;"picsubject_short"&#93;."\"&#58;
                                                                echo \"".$picsubject2&#91;"picsubject_short"&#93;."\";
                                                                echo \"".$picsubject2&#91;"picsubject_full"&#93;."\";
                                                                break;
                 ';
         echo $case;
         eval &#40;"\$case = \"$case\";"&#41;;
         //echo $case;
    
        &#125;
      &#125;
     mysql_close&#40;$zugang&#41;;
    
     $switch_close = '&#125;?>';
     echo  $switch_close;
     eval &#40;"\$switch_close = \"$switch_close\";"&#41;;
    ?>
    ich will das folgendes rauskommt:
    Code:
    <a href='index.php?show=pictures&picsubject=1SB' class='main'>
     1. Senzer Ball
    </a>
    
    
    <a href='index.php?show=pictures&picsubject=2SB' class='main'>
     2. Senzer Ball
    </a>
    
    
    <?
    switch &#40;$_GET&#91;picsubject&#93;&#41;
     &#123;
      case "1SB"&#58;
                 echo "1SB";
                 echo "1. Senzer Ball"; 
                 break; 
      case "2SB"&#58; 
                 echo "2SB";
                 echo "2. Senzer Ball";
                 break;
     &#125;
    ?>
    wieso funktioniert das nicht?

    danke schonmal im voraus für die hilfe!

    bye forsch
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Kaiserliche Hoheit
    Registriert seit
    15.07.2005
    Ort
    Hagen (NRW)
    Beiträge
    1.515
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Wenn du mir erklärst aufgrund welcher Informationen du welche Ausgabe generieren möchtest versuche ich dir zu zeigen, wie man das sauberer und übersichtlicher programmieren kann.

    Wenn ich ehrlich bin, habe ich jetzt nämlich nicht so die Lust mich in ein nicht Templateorientiertes System reinzudenken - das eval machts hier nicht grad einfacher...
    Zoggerforum.de Betreuer * Mod @ ibforen.de * Admin @ daoc-ds.de
    ICQ Nummer kann via PN erfragt werden

  3. #3
    Kaiserliche Hoheit
    Registriert seit
    22.02.2005
    Beiträge
    1.558
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Hier gehört auch n bissel mehr Info WAS nicht funktioniert bzw. WELCHE Fehlermeldung bzw. Fehlererscheinung es gibt. Ohne n bissel Infos bringt das alles nix. Man will ja auch nicht Stunden mit dem Script verbringen.
    "Carpe Diem" powered by positiv Feelings

  4. #4
    FR0SCH
    Gast

    Standard

    moin

    1.also es ist schwer zu erklären, was ich damit generieren kann
    2.es kommt keine fehlermeldung, das is ja gerade das komische
    3.ich habe jetzt eine andere lösung gefunden!!!

    trotzdem danke für die hilfe
    bye frosch

Ähnliche Themen

  1. Was mache ich bei diesem Bestellformular falsch
    Von turtles im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 21.11.2007, 15:45
  2. CreateEmptyMovieclip - Code auf diesem Clip?????????
    Von SaiyaGin im Forum Flash Forum
    Antworten: 0
    Letzter Beitrag: 04.10.2007, 12:39
  3. Was ist bei diesem Framecode falsch???
    Von gyrospitter im Forum HTML & CSS Forum
    Antworten: 8
    Letzter Beitrag: 25.01.2006, 12:04
  4. Frage zu diesem Code (Mousover)
    Von Masterfummel im Forum HTML & CSS Forum
    Antworten: 3
    Letzter Beitrag: 22.06.2005, 19:55
  5. Was ist an diesem code falsch der öffnet kein popup
    Von Jesus im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 26.11.2004, 19:25

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •