Ergebnis 1 bis 3 von 3

Thema: Browser Probleme mit Sound und Mouseover

  1. #1
    HTML Newbie
    Registriert seit
    27.08.2005
    Ort
    GRoß Gerau
    Beiträge
    9
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Browser Probleme mit Sound und Mouseover

    Hallo Leute,

    ich bin der neue hier und habe wohl auch gleich eine dämliche Frage

    Ich nutze im Moment Dreamweaver zum erstellen meiner HOmepage und bin lider auf einige Probleme gestoßen wo ich auf eure Hilfe hoffe.

    1. Ich habe Seiten mit Hintergrundmusik erstellt was unter Internet Explorer auch wunderbar funzt. Nur leider nicht unter Mozilla (neuste Version)

    2 Nächstes Problem unter Dreamweaver habe ich die Funktion Rollovereffekt genutzt um zwei Bilder zu wechseln sobald man mit der Maus darüber fährt. Diese Bilder dienen auch als Link. Problem hier es funzt unter Mozilla aber nicht unter Internet Explorer.

    Kann mir jemand helfen? Das komische ist das es mit de Bild oben Links ohne Probleme funktioniert.


    Hier mal der Seitencode bitte um Hilfe THX

    Code:
    <html>
    <head>
    <title>Marctrix Friends</title>
    <link rel="stylesheet" type="text/css" href="format.css" >
    <bgsound src="stuff/4friends.mid" loop="infinite">
    <script>
    <!--
    <!--         
    function BlurLinks&#40;&#41;&#123;
    lnks=document.getElementsByTagName&#40;'a'&#41;;
    for&#40;i=0;i<lnks.length;i++&#41;&#123;
    lnks&#91;i&#93;.onfocus=new Function&#40;"if&#40;this.blur&#41;this.blur&#40;&#41;"&#41;;
    &#125;
    &#125;
    
    onload=BlurLinks;
    -->
    
    function MM_preloadImages&#40;&#41; &#123; //v3.0
      var d=document; if&#40;d.images&#41;&#123; if&#40;!d.MM_p&#41; d.MM_p=new Array&#40;&#41;;
        var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for&#40;i=0; i<a.length; i++&#41;
        if &#40;a&#91;i&#93;.indexOf&#40;"#"&#41;!=0&#41;&#123; d.MM_p&#91;j&#93;=new Image; d.MM_p&#91;j++&#93;.src=a&#91;i&#93;;&#125;&#125;
    &#125;
    
    function MM_findObj&#40;n, d&#41; &#123; //v4.01
      var p,i,x;  if&#40;!d&#41; d=document; if&#40;&#40;p=n.indexOf&#40;"?"&#41;&#41;>0&&parent.frames.length&#41; &#123;
        d=parent.frames&#91;n.substring&#40;p+1&#41;&#93;.document; n=n.substring&#40;0,p&#41;;&#125;
      if&#40;!&#40;x=d&#91;n&#93;&#41;&&d.all&#41; x=d.all&#91;n&#93;; for &#40;i=0;!x&&i<d.forms.length;i++&#41; x=d.forms&#91;i&#93;&#91;n&#93;;
      for&#40;i=0;!x&&d.layers&&i<d.layers.length;i++&#41; x=MM_findObj&#40;n,d.layers&#91;i&#93;.document&#41;;
      if&#40;!x && d.getElementById&#41; x=d.getElementById&#40;n&#41;; return x;
    &#125;
    
    function MM_swapImgRestore&#40;&#41; &#123; //v3.0
      var i,x,a=document.MM_sr; for&#40;i=0;a&&i<a.length&&&#40;x=a&#91;i&#93;&#41;&&x.oSrc;i++&#41; x.src=x.oSrc;
    &#125;
    
    function MM_swapImage&#40;&#41; &#123; //v3.0
      var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array; for&#40;i=0;i<&#40;a.length-2&#41;;i+=3&#41;
       if &#40;&#40;x=MM_findObj&#40;a&#91;i&#93;&#41;&#41;!=null&#41;&#123;document.MM_sr&#91;j++&#93;=x; if&#40;!x.oSrc&#41; x.oSrc=x.src; x.src=a&#91;i+2&#93;;&#125;
    &#125;
    //-->
    </script> 
    </head>
    <body onLoad="MM_preloadImages&#40;'grafiken/neosaber.jpg','grafiken/gladiatormarc2.jpg'&#41;">
    <table border="0" cellpadding="0" cellspacing="0"  width="100%">
    <tr>
    <td width="20" ></td>
    <td align="center">
    [img]images/friends.jpg[/img]
    </td>
    <td width="30" ></td>
    </tr>
    </table>
    
    <table width="200" border="0">
      
      <tr>
        <td></td>
        <td></td>
        <td></td>
        <td></td>
        <td></td>
        <td></td>
      </tr>
      <tr>
        <td></td>
        <td></td>
        <td></td>
        <td></td>
        <td></td>
        <td></td>
      </tr>
      <tr>
        <td>[img]grafiken/neo.jpg[/img]</td>
        <td></td>
        <td></td>
        <td></td>
        <td></td>
        <td>[img]grafiken/gladiatormarc1.jpg[/img]</td>
      </tr>
    </table>
    </body>
    </html>
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Kaiserliche Hoheit
    Registriert seit
    15.07.2005
    Ort
    Hagen (NRW)
    Beiträge
    1.515
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Wegen der Hintergrundmusik:

    Dazu solltest du den < embed > Tag verwenden.

    Siehe auch: http://de.selfhtml.org/html/dateiwei....htm#einbinden
    (@ admin: hier passiert irgendwas blödes, wenn ich die Klammern normal um embed setze...)
    Zoggerforum.de Betreuer * Mod @ ibforen.de * Admin @ daoc-ds.de
    ICQ Nummer kann via PN erfragt werden

  3. #3
    HTML Newbie
    Themenstarter

    Registriert seit
    27.08.2005
    Ort
    GRoß Gerau
    Beiträge
    9
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Danke hierfür schon mal wenn ihr auch noch was für den Rest findet wäre richtig toll.

    Danke aber schon mal

Ähnliche Themen

  1. Mouseover mit Sound und Bildwechsel
    Von Chico im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 4
    Letzter Beitrag: 21.08.2007, 23:23
  2. Probleme mit dem Sound
    Von flipmoe41 im Forum Flash Forum
    Antworten: 1
    Letzter Beitrag: 10.03.2007, 15:20
  3. mouseover probleme
    Von lö im Forum Flash Forum
    Antworten: 2
    Letzter Beitrag: 01.08.2006, 08:29
  4. bei mouseover Bild vergrößern und ein Sound abgespielen
    Von erich im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 10
    Letzter Beitrag: 06.09.2005, 15:03
  5. bei mouseover, sound
    Von Metallica im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 06.03.2005, 21:14

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •